Our app is only available on selected devices. To use our app technology your device must be compatible, running Android 5.0 or higher or Apple iOS 10.0 or higher. 

Did this answer your question?